Footer

Your go-to destination for discovering trending open-source projects and uncovering the insights that matter

Legal

  • Terms and conditions
  • Privacy policy

More

  • Pricing
  • Advertise
  • onedump
  • gosnakego
  • Contact us

Social

  • X (Twitter)
  • GitHub
Trendshift owl
What they build speaks louder than words
© 2026 Trendshift, created by Julian Li with ❤️
SignalAdvertise
Trendshift
SignalAdvertise
Sign in
Trendshift owl

Discover trends that matter

DailyWeeklyMonthlyYearly
Live mentionsTopics
RepositoriesDevelopers
InsightsStats
Busbar
Busbar
Bifrost
Bifrost

jackpal/gateway

A golang library for discovering the address of a LAN gateway.

Visit GitHub
Go
250
73
15 contributors
BSD 3-Clause "New" or "Revised" License
FeaturedAdvertise to 180K+ monthly visitors
Busbar

Control what AI can do before it acts

Bifrost

Enterprise AI Gateway Built For Scale: Route, Govern, and Secure All Your AI Traffic

Momentum

How fast jackpal/gateway is gaining stars, and where it lands on Trendshift and GitHub Trending

Activity and trending

Stars, forks and merged pull requests each day or month, lined up with the repository's rank on Trendshift Trending

Sep 4 – Oct 18, 2026

Stars +2 in 45 days

01
1

Forks +0 in 45 days

01

Merged PRs 0 in 45 days

01

Trendshift Trendingwhere the repository ranked each day it made the top 25

Not in the Trendshift top 25 in this period

Sep 4Sep 10Sep 16Sep 22Sep 28Oct 4Oct 10Oct 16
The left and right arrow keys step from day to day; Home and End go to the first and the last

Stars, forks, merged pull requests and Trendshift Trending rank, by day
DayStars gainedForks gainedMerged PRs
Fri, Sep 4, 2026+0+00
Sat, Sep 5, 2026+0+00
Sun, Sep 6, 2026+0+00
Mon, Sep 7, 2026+0+00
Tue, Sep 8, 2026+0+00
Wed, Sep 9, 2026+0+00
Thu, Sep 10, 2026+0+00
Fri, Sep 11, 2026+0+00
Sat, Sep 12, 2026+0+00
Sun, Sep 13, 2026+0+00
Mon, Sep 14, 2026+0+00
Tue, Sep 15, 2026+0+00
Wed, Sep 16, 2026+0+00
Thu, Sep 17, 2026+0+00
Fri, Sep 18, 2026+0+00
Sat, Sep 19, 2026+0+00
Sun, Sep 20, 2026+0+00
Mon, Sep 21, 2026+0+00
Tue, Sep 22, 2026+0+00
Wed, Sep 23, 2026+0+00
Thu, Sep 24, 2026+0+00
Fri, Sep 25, 2026+0+00
Sat, Sep 26, 2026+0+00
Sun, Sep 27, 2026+0+00
Mon, Sep 28, 2026+0+00
Tue, Sep 29, 2026+0+00
Wed, Sep 30, 2026+0+00
Thu, Oct 1, 2026+0+00
Fri, Oct 2, 2026+0+00
Sat, Oct 3, 2026+1+00
Sun, Oct 4, 2026+0+00
Mon, Oct 5, 2026+0+00
Tue, Oct 6, 2026+0+00
Wed, Oct 7, 2026+0+00
Thu, Oct 8, 2026+0+00
Fri, Oct 9, 2026+0+00
Sat, Oct 10, 2026+0+00
Sun, Oct 11, 2026+0+00
Mon, Oct 12, 2026+0+00
Tue, Oct 13, 2026+0+00
Wed, Oct 14, 2026+0+00
Thu, Oct 15, 2026+0+00
Fri, Oct 16, 2026+0+00
Sat, Oct 17, 2026+1+00
Sun, Oct 18, 2026+0+00
Total+2+00
  • 1#1 on the list
  • 7Rank that day
  • Not trending

You might also like

Repositories close to jackpal/gateway
FeaturedAdvertise to 180K+ monthly visitors
Busbar

Control what AI can do before it acts

Bifrost

Enterprise AI Gateway Built For Scale: Route, Govern, and Secure All Your AI Traffic

sindresorhus/internal-ip

JavaScript

Get your internal IP address

35026

digineo/go-ping

Go

A simple ping library using ICMP echo requests.

25035

hashicorp/go-sockaddr

Go

IP Address/UNIX Socket convenience functions for Go

29059

ccding/go-stun

Go

A go implementation of the STUN client (RFC 3489 and RFC 5389)

721127

sindresorhus/public-ip

JavaScript

Get your public IP address - very fast!

1.1k69

osociety/vernet

Dart

Cross platform network analysis and monitoring tool

55550

mdlayher/arp

Go

Package arp implements the ARP protocol, as described in RFC 826. MIT Licensed.

39170

bevry/getmac

TypeScript

Get the mac address of the current machine you are on via Node.js

36053

mpolden/echoip

Go

A simple IP address lookup service.

4.4k533